0.10.0 Release candidate 4


#21

@stephanschulz can you open an issue on github?


#22

Quick appointment there. Another solution to avoid this issue (for a clean VS2017 VS community) is to do not forget add Window 8.1 SDK during the installation. But that’s an additional step… that can be missed easily.


#23

I tried to include unicode characters as follows;

ofTrueTypeFontSettings settings("verdana.ttf", 14);
settings.addRanges(ofAlphabet::Latin);
settings.contours=true;
settings.antialiased=true;

I can’t display “ğ,Ğ,ı,İ,şŞ”. I’ve just add the following line (LatinA chars range) to ofTrueTypeFont.h

static const range LatinA;

And, to ofTrueTypeFont.cpp

const ofUnicode::range ofUnicode::LatinA {0x0100,0x017F};
const std::initializer_list<ofUnicode::range> ofAlphabet::Latin {
    ofUnicode::Latin1Supplement,
    ofUnicode::LatinExtendedAdditional,
    ofUnicode::LatinA
};

Now, Latin alphabet includes full Turkish language character set.


#24

Oh thanks for that, we’ll surely do a patch release 0.10.1 with this kind of fixes in a couple of weeks


#25

where can I find the repository for windows version?


#26

Hallo I’m trying to setup openframeworks 0.10 for gcc6 on Ubuntu 18.04
Executing :

cd OF/scripts/linux/ubuntu
sudo ./install_dependencies.sh

I got the problem:

Installing libgl1-mesa-dev-hwe-18.04
E: Unable to locate package libgl1-mesa-dev-hwe-18.04

I read about this Problem but I dont know if this has influence on the compile process?

Then I try the next step:

cd OF/scripts/linux
./compileOF.sh -j3

I got this Problem:

/home/alphi/OF/libs/openFrameworks/utils/ofUtils.cpp:16:27: fatal error: uriparser/Uri.h: No such file or directory
#include “uriparser/Uri.h”
^
compilation terminated.
makefileCommon/compile.core.mk:238: recipe for target ‘/home/alphi/OF/libs/openFrameworksCompiled/lib/linux64/obj/Debug/libs/openFrameworks/utils/ofUtils.o’ failed
make[1]: *** [/home/alphi/OF/libs/openFrameworksCompiled/lib/linux64/obj/Debug/libs/openFrameworks/utils/ofUtils.o] Error 1
make[1]: *** Waiting for unfinished jobs…
makefileCommon/compile.core.mk:212: recipe for target ‘Debug’ failed
make: *** [Debug] Error 2
there has been a problem compiling Debug OF library
please report this problem in the forums

I search for the uriparser/Uri.h" and find it a the path /home/alphi/OF/libs/uriparser/include/uriparser/Uri.h
Any suggestions ?
Thx


#27

Hey!

I tried replicating your error on my machine yesterday, but no luck.
My setup is gcc5 and ubuntu 16.04, and the install was smooth.

Have you tried to use the gcc-5 or running updates for gcc?

will try an update of gcc this ev if I’ve got time.

++