0.10.0 Release candidate 3


#62

@genleung_lan the problem i think is that you are trying to allocate too many glyphs. Textures in desktop allow for much bigger sizes but in the raspberry pi they are limited to a smaller size (don’t know exactly how much right now)

Instead of trying to allocate all of CJK + Latin in one font you can try to load only CJKUnified in one font and then another for latin.

You can also use: getStringTexture to get a specific text in a texture which will only need to load the specific characters you are asking for. Don’t use this every frame though since it will be slow. But you can pre-allocate the texts in setup and use them after. Also aligning text with this method can be tricky since the position will be from the top left corner instead of the baseline of the text.

The solution for this is to allocate more than one texture per font if needed and create an index to know in which texture each character, we might include it for next release

By now i’ve included a check in ofTruetypeFont to show an error in case the texture needed is bigger than the maximum supported in each platform


#63

@arturo android studio is nice, but bloated, compile taking 2 procs each with 200+% cpu usage, code completion procs etc. i’m with a crappy system doesn’t let me uninstall nvidia drivers, i need all optimizations on for more battery time, can only charge once in a while – please don’t deprecate the make path. already seems so nice and ready to use. if you could share some ptrs how to use it, how to make it work with, for example,

make Release PLATFORM_OS=Android cradle=/~/Android/Craddle ndk=/path/to/gcc-arm-none-eabi-7-2017-q4-major sdk=/path/to/lowest/android/sdk/version  (or these paths could go into paths.make?)
make install

anyways i tested one example 0.10rc4 with android-studio and finally worked


#64

@unicatcorn the makefiles never worked on their own, only to compile the native libary but then we always needed other system to compile the java side and deploy. Before android studio we used eclipse but that was deprecated by android and doesn’t work anymore