0.10.0 Release candidate 3


#1

Hi all

After a week of testing and fixing some remaining issues with the 1st release candidate, here’s v0.10.0 RC2 (RC2 had a problem with the project generator in visual studio so we are releasing RC3 right away which solves that problem).

The main fixes have been:

It would be really useful if you could download the packages for the platforms you use and report if you notice any issues.

One of the major changes in 0.10.0 is the move to glm as our vector math library substituting the ofVec and ofMatrix classes. The old classes are still there and you don’t need to move to glm right away, indeed old projects should work with some minor adjustments since ofVec and glm::vec classes are interchangeable. We’ll post some more information about this and other new features in the following days.

It would be really helpful, if you could try running existing projects with 0.10.0 RC2 0.10.0 RC3 to see if issues arise but 0.10.0 is a major version change and as such there’s some breaking changes so testing old projects will likely require some changes in your code. Feel free to ask in this same thread if you find any problem migrating old projects.

If you find any other problem in the release please open an issue in the github issue tracker.

Windows – Visual Studio 2017: http://openframeworks.cc/versions/v0.10.0RC3/of_v0.10.0RC3_vs2017_release.zip

Windows – msys2 & Qt Creator: http://openframeworks.cc/versions/v0.10.0RC3/of_v0.10.0RC3_msys2_release.zip

mac OS – Xcode & emscripten: http://openframeworks.cc/versions/v0.10.0RC3/of_v0.10.0RC3_osx_release.zip

linux 64 – makefiles & Qt Creator & emscripten: http://openframeworks.cc/versions/v0.10.0RC3/of_v0.10.0RC3_linux64gcc6_release.tar.gz

Android Studio: http://openframeworks.cc/versions/v0.10.0RC3/of_v0.10.0RC3_android_release.tar.gz

iOS – Xcode: http://openframeworks.cc/versions/v0.10.0RC3/of_v0.10.0RC3_ios_release.zip

linux armv6 (raspberry pi) with raspbian – makefiles: http://openframeworks.cc/versions/v0.10.0RC3/of_v0.10.0RC3_linuxarmv6l_release.tar.gz

linux armv7 (tested mostly on raspberry pi with archlinux) – makefiles: http://openframeworks.cc/versions/v0.10.0RC3/of_v0.10.0RC3_linuxarmv7l_release.tar.gz

Because of relatively recent changes in the way c++ is compiled by gcc, the linux versions above are only compatible with gcc 6 or later. if you have an older distribution in linux desktop you can check your gcc version with

gcc -v

and use the corresponding version:

linux 64 gcc4 or earlier – makefiles & Qt Creator & emscripten: http://openframeworks.cc/versions/v0.10.0RC3/of_v0.10.0RC3_linux64gcc4_release.tar.gz
linux 64 gcc 5 – makefiles & Qt Creator & emscripten: http://openframeworks.cc/versions/v0.10.0RC3/of_v0.10.0RC3_linux64gcc5_release.tar.gz

If everything goes well we’ll do a final release next monday

Thank you for helping test the 0.10.0 release!
Arturo


ProjectGenerator.exe on Windows
#2

#3

Since I have a fresh installation of Windows on my new laptop, and will have to wait a bit before I can install a second SSD and dual boot to Linux: would you recommend VS2017 or QT Creator?


#4

vs2017 is simpler to install, qt creator has the advantage of being multiplatform and perhaps simpler to use


#5

Hi @arturo, thanks for putting this together.
I’m running the buildAllExamples script on macos and there are several errors, some of which probably will appear on other platforms too. I’ll make the needed changes and PR in github.
best


#6

@arturo The project generator in windows seems to have problem, it returns error when importing any project, i’ll post details on github


#7

@drakko yes, thanks, it’s been already reported, i’m fixing it right now


#8

@roymacdonald could you add references to any of the issues you open in this thread?


#9

@theo sure. I’m working on it right now.


#10

@drakko I’ve fixed the problem with the PG in windows and done a new release candidate, the links are in this same post, if you can test that it works fine for you?


#11

@arturo @theo, just made a PR with the fixes for examples.


#12

hey can’t compile a simple shader project that works on 9.8
i get this error:
Command /bin/sh failed with exit code 23

building file list ... done

sent 80 bytes  received 20 bytes  200.00 bytes/sec
total size is 775846  speedup is 7758.46
building file list ... done

sent 86 bytes  received 20 bytes  212.00 bytes/sec
total size is 2294756  speedup is 21648.64
building file list ... rsync: link_stat "/Volumes/GhOsT/Creative-Coding/OF/of_v0.10.0RC3_osx_release 2/apps/myApps/DephShader/../../../libs/glut/lib/osx/GLUT.framework" failed: No such file or directory (2)
done

sent 29 bytes  received 20 bytes  98.00 bytes/sec
total size is 0  speedup is 0.00
rsync error: some files could not be transferred (code 23) at /SourceCache/rsync/rsync-45/rsync/main.c(992) [sender=2.6.9]
Command /bin/sh failed with exit code 23

#13

Have you tried updating the project with the project generator?


#14

I am currently downloading I will port a huge project in it, if there is a bug it will show.

I have visual studio 2015 currently, will it work?
I am downloading community…


#15

we only support vs2017 officially


#16

Is there a guide on what components are needed etc? I will go with minimum


#17

i think you need at least a windows SDK


#18

I successfully built my Windows 10 Visual studio project with RC1.

Now I am trying RC3 and I am getting errors like
Error LNK2019 unresolved external symbol __imp__CertOpenStore@20 referenced in function _capi_open_store
from libcrypto.lib.

So I tried making an app with the project generator with no addons and no code changes and I still get the same link errors.

By the way, I have both VS2015 and VS2017 installed on my computer and when I use the project generator it only gives me the option to build for 2015 which is rather strange


#19

Can you give me some information to try to debug why this is happening?

I imagine you are using ofxPoco? and some addon to download from https? can you specify which? or any other addons you are using in your application


#20

Hi Arturo, I have no addons included at all

ll