0.05 Linux Makefile

Can you guys hook a brother up w/ the 0.05 Makefile version of OF? I’m especially excited about the video capture improvements for Linux in this version. So far I haven’t gotten that stuff working in 0.04.

Thanks,
Brian

I whipped up a Makefile for the 0.05 movieGrabber example.
You’ve probably already worked around this but someone else might find it useful…

People using 0.05 in Linux have to do the following first (in addition to the usual stuff):

  
sudo apt-get install libraw1394-dev  

the Makefile:
http://www.digitalstar.net/openframeworks/Makefile-0.05

Based on your makefile I created a working Makefile for the opencvExample in ver 0.05. Download from

http://zarzamora.com.mx/of/Makefile.opencvExample

rename to ‘Makefile’ and put it into apps/addonsExamples/opencvExample type make and then run bin/clickToLaunchApp.sh

I think OF needs makefiles because these are the most generic in linux. Codeblocks is decent but not the most widespread, Makefiles work all the time.

BTW unicap is still broken in linux and selects MJPEG in my case, which doesn’t work.

To solve that issue you can substitute video/ofUCUtils.cpp with this one:

http://65.111.166.199/openframeworks/ofUCUtils.cpp

There was a problem in the original one that can make it select a format not supported by unicap.

[quote author=“arturo”]To solve that issue you can substitute video/ofUCUtils.cpp with this one:

http://65.111.166.199/openframeworks/ofUCUtils.cpp

There was a problem in the original one that can make it select a format not supported by unicap.[/quote]

I replaced the file and only got worse

  
  
In file included from ../../../libs/openFrameworks/video/ofUCUtils.cpp:11:  
../../../libs/ffmpeg/libavcodec/avcodec.h:2474: aviso: se descarta el atributo en la declaración de ‘struct ImgReSampleContext’  
../../../libs/ffmpeg/libavcodec/avcodec.h:2474: aviso: el atributo para ‘struct ImgReSampleContext’ debe estar a continuación de la palabra clave ‘struct’  
../../../libs/ffmpeg/libavcodec/avcodec.h:2485: aviso: ‘ImgReSampleContext’ es obsoleto (declarado en ../../../libs/ffmpeg/libavcodec/avcodec.h:2479)  
../../../libs/ffmpeg/libavcodec/avcodec.h:2495: aviso: ‘ImgReSampleContext’ es obsoleto (declarado en ../../../libs/ffmpeg/libavcodec/avcodec.h:2479)  
../../../libs/ffmpeg/libavcodec/avcodec.h:2501: aviso: ‘ImgReSampleContext’ es obsoleto (declarado en ../../../libs/ffmpeg/libavcodec/avcodec.h:2479)  
../../../libs/ffmpeg/libavcodec/avcodec.h:2506: aviso: ‘ImgReSampleContext’ es obsoleto (declarado en ../../../libs/ffmpeg/libavcodec/avcodec.h:2479)  
  
<--- cut lenghty output--->  
  
../../../libs/openFrameworks/video/ofUCUtils.cpp:472: error: ‘capture_mutex’ no se declaró en este ámbito  
make: *** [obj/ofUCUtils.o] Error 1  
  

By the way, can someone tellme how to change gcc output to english. I just hate spanish output.

So, I downloaded the Linux CodeBlocks version of 0.05, but I am running it on Gentoo. I put this Makefile into the movieGrabber example:

http://www.digitalstar.net/openframeworks/Makefile-0.05

and replaced my ofUCUtils with

http://65.111.166.199/openframeworks/ofUCUtils.cpp
http://65.111.166.199/openframeworks/ofUCUtils.h
Building goes just fine, but when I run it I get this errors:

Unicap : Error selecting device 0
Unicap : Using device
Unicap : Using module
Unicap : Available formats for this device:
1647 Segmentation fault

The window shows up for a split second, and then I get that error. Any ideas?

From the output it seems that unicap is not detecting your device, can you post what camera are you using? Also try listing the available devices with:

  
  
vidGrabber.listDevices();  

to see if your device is being correctly detected.

There’s some steps to follow with non working devices in this post:

http://forum.openframeworks.cc/t/video-capture-in-0.05/556/0

try, specially ucview, if it doesn’t work, then your device doesn’t work with the unicap module.

Also, you can try with the pre pre release of 0.06:
http://65.111.166.199/openframeworks/of-preRelease-v0.059-linux-cb-FAT.tar.gz

There’s some bug fixes in the video grabber and the last version of unicap that should solve many problems, mostly with v4l2 and yuv devices, and it shouldn’t break your old code.

Apart from that, although you are in gentoo you should be able to use codeblocks:

emerge -av codeblocks

or if you want the last development version, that solves some problems with run and debug:

http://wiki.codeblocks.org/index.php?title=Installing-Code::Blocks-from-source-on-Gentoo

The thing is, we aren’t using any device. I am just trying to get the videograber example running.

Ah – I will try the 0.06 version.

Thanks so much.

then the problem is really easy: the videograbber example won’t work without a camera, because it’s the example to grab video from a camera :slight_smile:

perhaps you want the videoplayer example? that’s the one for playing a video file.

so right. so right. I was trying the wrong one.

:oops:

Thanks for your help.

Hi, I just thought I’d add a link here to the post about the Makefile generator script I have been working on:

http://forum.openframeworks.cc/t/makefile-generator-cbp2makefile.py/1519/1

pix.